SDRAM not playing ball

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi all,

There's been a bit of a lull of activity at work so I brought the STK1000 home for the week. Upon getting it home, setting it up on my workbench and powering it up, I found something not so great:

U-Boot 1.1.4 (Oct  1 2006 - 12:54:54) 



U-Boot code: 00000000 -> 000111cf  data: 24000000 -> 24002bf0

SDRAM: 8 MB at address 0x10000000

Testing SDRAM...FAILED at address 0x10000000

SDRAM: read 0x100000, expected 0x0

malloc: Using memory from 0x0ffc0000 to 0x10000000

Flash: 3842 MB at address 0xf01ff01f

DRAM Configuration:

Bank #0: 70987098 3842 MB

WARNING: Cannot allocate space for boot parameters



 *** Unhandled exception 3 at PC=0x481f0000

Bus error at address 0xffffffff

   pc: 481f0000    lr: 000058fe    sp: 24007f20   r12: 0000fe70

  r11: 0000fe70   r10: fffffff0    r9: 00000002    r8: 481f0000

   r7: 24008000    r6: 0ffc0008    r5: 24007fac    r4: e9afcfa5

   r3: 24000ccc    r2: 10000000    r1: 00000000    r0: 00000014

Flags: qvnZc

Mode bits: hrje....G

CPU Mode: Supervisor



Stack: (0x24007f20 to 0x24008000)

7f20: 00005c56 000062ce 0ffc1000 000024cc 0000000a 0000692e 24008000 0ffc0008 

7f40: 24007fac e9afcfa5 24000ccc 10000000 00000000 0000696e 000002b4 24008000 

7f60: 0ffc0008 24007fac e9afcfa5 31313532 3030005f bb2b8120 136f7cb5 cb22f19c 

7f80: 39b6641b 54c1118c 88684dc5 578331dc a4b8dd74 92f40c43 e889f4df 7c115298 

7fa0: 8f154f1a f4636ba8 a07624c0 0ffc0008 00000000 0000acd0 0000ac94 0001c200 

7fc0: 00000000 00000001 00000000 00000004 00000001 08583b00 00000000 00007e70 

7fe0: 24008000 24000948 24007fac e9afcfa5 24007f20 0000003f 00000000 00000014 

Unhandled exception

This seems pretty unequivocal, my SDRAM didn't survive the trip. This is a bit odd as my home workbench is still antistatic etc. The only thing I noticed in the trace which gave me a glimmer of hope is that U-Boot is very confused about the size of everything: Flash: 3842 MB at address 0xf01ff01f, Bank #0: 70987098 3842 MB. I have tried updating the flash with the u-boot from the BSP, my own built u-boot 1.1.4 and u-boot 1.1.6, all with the same results.

Anyone got any ideas before I go swapping RAM? If it is dead at least it gives me a chance (read: excuse XD) to upgrade!

S.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

squidgit wrote:
Hi all,

There's been a bit of a lull of activity at work so I brought the STK1000 home for the week. Upon getting it home, setting it up on my workbench and powering it up, I found something not so great:

Testing SDRAM...FAILED at address 0x10000000
SDRAM: read 0x100000, expected 0x0

Looks like it wraps around at 1 MB. Everything from here on is bogus -- u-boot should really hang instead of continuing here.

Before you go ahead and swap the RAM, I suggest you check that the top card is properly seated. Maybe it was shaken loose during the trip...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

lol, yeah, that oughdda do it :oops:

I had tried that before but I obviously wasn't persuasive enough the first time around XD;;

S.