SAM3X8E Arduino due bossac error in Atmel Studio 7.0

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello,

 So ive been trying to learn and use Atmel Studio 7.0 with a Arduino Due,and run the example code USART_USART_SERIAL_EXAMPLE2 code found in the examples of Atmel and a simple example from here: https://medium.com/@eestuffs/how-to-program-arduino-due-using-atmel-studio-3c98014ac69e

 

 The build is successful but when I try to go into external tools and choose the setup I used to program it, I get:'bossac.exe: extra arguments found
Try 'bossac.exe -h' or 'bossac.exe --help' for more information '.

 

I setup my configure tool the same in both examples, checked and made sure my COM port was correctly choosen, and made sure I chose the correct username when typing in path to the file.

I tried this fix:  https://arduino.stackexchange.com/questions/24143/unable-to-upload-to-arduino-due-using-version-1-6-8-of-sam-tools-bossac-exe-thr

Which had me go into arduino15 file and open the bossac file,but when I try it never opens. I tried and made sure I was running as administrator and nothing....any help would be great. And apologies I come from the Arduino side of things and figured it was time to move on from there, sick and tired of looking up arduinos "magic numbers/words" in its source....

Thanks