Running ATmega4809 @ 20MHz???

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

There is no way except, maybe, with an external clock??

 

Selecting the internal 20MHz oscillator it will always be divided by at least 2 by the divisor so no 20MHz! It runs @10MHz.

This topic has a solution.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

Last Edited: Thu. Jun 14, 2018 - 10:01 PM
This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

You can disable the prescaler.

 

Last Edited: Thu. Jun 14, 2018 - 04:50 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Clear MCLKCTRLB bit 0? (PEN - Prescaler enable). (just guessing...)

 

Bit 0 – PEN Prescaler Enable
This bit must be written '1' to enable the prescaler. When enabled, the division ratio is selected by the PDIV bit field.

When this bit is written to '0', the main clock will pass through undivided (CLK_PER=CLK_MAIN), regardless of the value of PDIV.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thank you, that does it. I was reading bit 0 as being some form of interlock bit to enable the change. blush

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly