problem simulating 1281 UART using Proteus

Go To Last Post
6 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi!

I simulate data transfer between 1281 mcu using Proteus.
Mega 1281 received data from terminal is ok, and data transferring to Mega 1281 is also fine, but transferring from one Mega 1281 to another is bad (UDR0 register show incorrect incoming data).

Somebody has this problem or know what to do? :)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I would just ERASE Proteus and use real chips.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

In real chip is work fine, but in Proteus i don't need every time to programing chip to test :)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Surely you just ask LabCenter for support?

After all that is why you bought your licence for Proteus.

David.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

i don't need every time to programing chip to test

If simulators are teaching young engineers that "programming by grapeshot" is a good technique to use then it's a very sorry day indeed.

You shouldn't be downloading new code every few seconds to "see if something works". You should take some time out to know what works. implement it, download it and if you have introduced a bug in that implementation then fix it (but again by thinking not repeatedly programming).

As such the few seconds it takes to program a real AVR should have little influence on your overall day.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:
the few seconds it takes to program a real AVR
Particularly if you have a JTAG attached to the board.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly