Problem with project "Tardyon Drive AVR Stepper Controller"

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I tried to get the project "Tardyon Drive AVR Stepper Controller"
(https://community.atmel.com/proj...)
running, but without luck...
I used the precompiled hex-file for the ATtiny85 and the fuse-settings from
the flash.sh script: L-Fuse=0xe1 H-Fuse=0xdd E-fuse=0xfe.
But my board is not recognized when I connect it to USB (it uses VUSB),
There ist no Windows-Message and not a new HID-Device shown in
USBDeviceTreeviewer (https://www.uwe-sieber.de/usbtre...).
The schematics shows, that USB_D+ and USB_D- pins are swapped compared to
the popular Digispark-Boards. So if I swap these pins, directly at the
ATtiny-Chip (pins 2 and 3) and flash the controller with the Digispark-
Bootloader, everything works well and the device is shown correctly with
USBDeviceTreeViewer. I flashed the Tiny with avrdude and veryfied program
and fuses. Also I tried two different programmers, two computers with
Windows XP and Windows 7 and two different (selfmade) PCBs and two ATtinys
in every combination - with the same result...
Where is the fault? What am I doing wrong?
Has anyone experience with the "Tardyon Drive AVR Stepper Controller" project
and can confirm, that it works with AtTiny85?

 

With best regards
Arno