problem compiling libart-lgpl for avr32

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello all,
Has someone compiled a library for avr32-linux? I got the following error:

$ env CFLAGS="-O3 -fPIC" ./configure --host=avr32-linux --disable-shared --prefix=/usr/avr32-linux
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets $(MAKE)... yes
checking for working aclocal-1.4... missing
checking for working autoconf... found
checking for working automake-1.4... missing
checking for working autoheader... found
checking for working makeinfo... missing
checking for avr32-linux-gcc... avr32-linux-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... yes
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether avr32-linux-gcc accepts -g... yes
checking for avr32-linux-gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... avr32-linux-gcc -E
checking build system type... i686-pc-linux-gnu
checking host system type... Invalid configuration `avr32-linux': machine `avr32' not recognized
configure: error: /bin/bash ./config.sub avr32-linux failed

Has someone a idea what is going wrong?

Frank

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Please search around the forums or the cross compiling guide on avr32linux.org; this error is caused by the config.sub in the package being old. Google for a new one; job done.

-S.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thank You squidgit,
I never realized that such a cross compiling guide exists. I will try it again with new config.sub and config.guess scripts.

Frank

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The new config.sub and config.guess solved the biggest problem while compiling libart_lgpl. Another problem is, that in the make process first a file is compiled and tried to run. This little program "gen_art_config" creates a header file which defines the data types for the machine libart runs on. While it is compiled with avr32-linux-gcc it cannot run on the host. So I copied the executeble file to the ngw-100, ran it and copied the created header file back to the host. In the Makefile I commented out the line:
#./gen_art_config > art_config.h
and executed make again. Now it worked and I have the libart_lgpl done for avr32.

Thanks for the help
Frank