Problem burning bootloader to ATMega32U4-MU

Go To Last Post
2 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I designed a very simple 4*3 keypad system controlled by an ATMega32U4-MU MCU, using Adafruit's Itsy-bitsy 32U4 as reference (attached is the schematic of my circuit, while Adafruit's circuit can be found at https://learn.adafruit.com/assets/49818). There is a 16 MHz oscillator on board (FA-20H 16.0000MF10Z-AJ0) with 22pF caps.

To program the circuit, I am trying to use an Arduino Uno set as ISP, using the following link as reference: https://www.designedbycave.co.uk/2020/ItsyBitsy-Bootloader/ Connections:

Arduino -> Atmega32u4 board
5V      -> 5V
GND     -> GND
10      -> RST
11      -> MOSI
12      -> MISO
13      -> SCK

I tried burning bootloader using both Arduino IDE (set board to Itsybitsy 5V 16 Mhz and later on Arduino Leonardo) and WinAVR CLI (Caterina bootloader downloaded from https://learn.adafruit.com/introducting-itsy-bitsy-32u4/downloads). Both show the invalid device signature verbose error.

I was having similar problems with an ATmega328P board earlier, which I solved by connecting pin 10 of Arduino directly to RST pin of target board instead of DTR pin (many people suggested oscillator issues, connection issues, circuit issues, capacitor issues etc. but those were not right). But here, the RST pin is already directly connected to RST pin of the MCU.

I checked for circuit error and shorts but found none. Everything was electrically intact. I made three of these boards and all three have the same issues.

Kindly look into the schematic and suggest what's wrong.

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Welcome to AVRFreaks!

 

swapnilsayansaha wrote:
I designed a very simple 4*3 keypad system controlled by an ATMega32U4-MU MCU, using Adafruit's Itsy-bitsy 32U4 as reference

Well your schematic is incomplete, it does not show the power supply, only VCC and GND connections.  It does show VBUSS pin connected to VCC, while the reference schematic shows it connected to vbus pin on the USB connector, your vbuss pin just goes to a label??? 

Your schematic is very hard to read, redraw it with ALL vcc arrows UP, and all gnd symbols DOWN, make all of the wiring connections, don't rely on net names for connections, yes, cad programs can keep track of the that, but humans can not, as I said, it's hard to read.

 

It's important that all VCC + AVCC pins are powered, and all GND pins are grounded and each vcc/gnd pin pair needs a 100nf cap as close to the pins as possible.

Before programming, test connections by trying to read the device signature.  Nothing will work until that test works.

 

Jim

 

 

(Possum Lodge oath) Quando omni flunkus, moritati.

"I thought growing old would take longer"