Problem in the beginning itself

Go To Last Post
8 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'm a totally new to AVR studio. I installed it couple of days back. Using Ubuntu 10.04 OS. As soon as I open AVR studio, the following lines appear in the message window:
Error creating DOMDocument object, to work properly the XML-parser in Internet Explorer version 4.01 or later must be present on the machine. Make sure you have IE5 or later installed
Loaded plugin STK500
gcc plug-in: No WinAVR installation found. The AVR GCC plug-in can still be used if you set up your own build tools.

What could be the reason for this.? How do I get rid of these messages?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

You mean you are trying to run it under "wine"? (clearly you cannot run a Windows program in Ubuntu otherwise)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

@clawson : Yes, I'm running it in "WINE"

Last Edited: Wed. Oct 13, 2010 - 03:14 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Also, When I click to create a new project, the system hangs and becomes non-responsive. Ultimately I'll have to force quit the application(AVR studio). Kindly help me out with this as well.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

So how did you setup the wine to run AVR Studio? If you search here you will fid a post by "aor_dreamer" that includes a PDF as an attachment that tells you exactly how to setup wine to run AVR Studio. It worked for me.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I guess its not an issue with WINE setup. Coz' the application opens. Only after that the problem arises.

However I read through the pdf suggested by you. It says that we have to install IE6. :? I'm not sure what the browser has to got to do with this. I use Mozilla firefox.

Kindly throw some light on this

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

I'm not sure what the browser has to got to do with this.

Studio uses the XML parsing lib that is installd by IE6+

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Oh Ok. Thanks a lot :)
I'll try installing IE6 or above and try running Studio again.