problem with avrisp mkii and stk500.exe

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hello,
i am one of the lucky guys who already received an avrisp mkii. it works fine with avrstudio v4.12 (build 462).

but now i tried to program with stk500.exe and got the following error message:

Could not connect to STK500 V2 on USB

the command line looks like this:
stk500 -dATMEGA128 -cusb -ef -pf -vf -iftest.a90 -f0x021f -E0xfe

any ideas?

regards
gerhard

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Is this the same question as this one posted on 07-Feb?
https://www.avrfreaks.net/index.p...

Lee

You can put lipstick on a pig, but it is still a pig.

I've never met a pig I didn't like, as long as you have some salt and pepper.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hello again,
i already found the reason for my problem:
"-cUSB" is the correct parameter for the communcation port. so this "nice" tool is case sensitive at this parameter.

regards
gerhard

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If you look at the help page displayed with "stk500 -h", you'll see that there are several commands using the same letter, one uppercase, one lowercase. So yes, the tool has to be case sensitive.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

dksmall wrote:
If you look at the help page displayed with "stk500 -h", you'll see that there are several commands using the same letter, one uppercase, one lowercase. So yes, the tool has to be case sensitive.

until now the tool was not case sensitive for the parameter values. you can use "-ccom1" and also "-cCOM1".
btw: USB is not mentioned in case of "stk500 -h".

regards
gerhard