Prevent AVR Studio from loading program when using JTAG?

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Sometimes I just want to use JTAG to debug a program that is already in the AVR rather than re-loading from the project.

I asked this question 2 years ago and got an answer that worked. It was some box to check or uncheck.

But that was then and this is now. I forgot where the box was. I'm now using the latest Studio so they probably hid that box from me.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Look in the JTAG ice options during a debug session.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks John. I think it was you that gave me the clue last time.

I remembered I had to have JTAG running to find the option, but I still couldn't find it. I kept looking at the Tools > options, and I never noticed the JTAG options at the bottom of the Debug window.

Well, I flunked the IQ test again! :)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

steve17 wrote:
Well, I flunked the IQ test again! :)
:lol: Not any more than the rest of us have!

I think the real problem with the way that AVR Studio has this set up is that everyone expects to be able to prevent the load before they get into debug mode with the JTAG. Funny thing, there is an option for that, but it doesn't do what one would expect. It is counter-intuitive that one must get into JTAG debug mode before being able to tell the debugger to not program the processor before debugging.

Oh well.

Stu

Engineering seems to boil down to: Cheap. Fast. Good. Choose two. Sometimes choose only one.

Newbie? Be sure to read the thread Newbie? Start here!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I flunked Stu. I remembered the chicken and egg problem. I knew I had to be running JTAG. But I still couldn't find the option.