[OT]: Step up converter coil makes a hiss/crackling noise

Go To Last Post
10 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello,

yesterday i bumped my head on a project where i need to run a lappy in my car, and didn't want to use an UPS or any commercial 12 to 'kill your self when its humid voltages'.

So ive constructed a simple step up, works ...
BUT

The coil is singing / crackeling making a screaming cricket noise under light loads. The noise is gone when under a heavy load.

Its unbeareable, what should i do with the coil or circuit to make it stop screaming?

Everything was DIY in this project except for the pwm MC34063 chip.
Ive used an IRFZ44N as transistor with a class B driver to drive the 1nF fat gate .. gate driving edges are very sharp and thight!

:(

MY MICROCONTROLLER CAN BEAT THE HELL OUT OF YOUR MICROCONTROLLER /ATMEL

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Sounds like under light loads the regulator is becoming unstable, operating
in bursts of pulses that repeat at an audible rate. Perhaps a signal grounding/
routing/feedback/compensation problem? What frequency is it supposed to be
operating at and what kind of inductor is it? Hand-wound, ferrite, varnished, etc.
Can you put a scope on it while it is making noise?

Tom Pappano
Tulsa, Oklahoma

Tom Pappano
Tulsa, Oklahoma

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi, ive been using wirewhick for all the power signals.. soaked with solder.
so all the current carrying signals are ready to handle high currents, order of 20 amps would be no problem.

Yes it does seem like the regulator is making short bursts with a repetitive frequency within the audiable range.

Ive been poking with th scope, but i cant see any real ground signals being lifted up.
The ground wire is configured as a star, so every earth is its own. Except for the dc bufferung caps there are about 4 all the way towards the cenral ground wire.

The coil is a toroid, hand wound with beefy solid copper wire. the exact indutance is unknown as i had no specs of the core,, but from eye-estimation its well suited.

the noise itself becomes visible on the scope as irregular bursts parterns

like this:

Vgate:    ||| ||| |       |||||||   ||| ||    ||||| | | | |||||             
       -> time

when it doesn't scream its like this:

Vgate:    |||||||     |||||||     ||||||     ||||||    |||||
       -> time

MY MICROCONTROLLER CAN BEAT THE HELL OUT OF YOUR MICROCONTROLLER /ATMEL

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

scope signal taken from gate

Attachment(s): 

MY MICROCONTROLLER CAN BEAT THE HELL OUT OF YOUR MICROCONTROLLER /ATMEL

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Get a resistor and give it a minimum load so it stays in reg and Bob's Your Uncle

Imagecraft compiler user

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi. A few thoughts of mine:

It seems to me that the feedback circuitry is not fast enough. You may need to change (decrement maybe?) the value of the voltage feedback decoupling capacitor, and/or the impedance of the feedback resistor ladder.

Can the load capacitors handle the high frequency ripple?

Are you sure that the mosfet Vds is high enough? Try connecting a 62V zener between the drain and the gate, when you hear the crackle: If it stops you need a higher voltage mosfet.

There is also another thing: You do not need a sharp rising edge for the gate drive. The coil takes care of it! Only the cut-off should be fast. Try a 22Ω current limmiting resistor in series with the gate.

Giorgos.

I hope for nothing; I fear nothing; I am free. (Nikos Kazantzakis)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi guys,
@ Bob,
ehh i meant light load eg 5 to 50%, not 'no load'.

@Giorgos
feedback circuitry , ive been fiddeling with it, but it was good as it was.

Result of a day fiddeling:
KLABOOM! it managed to go bezerk the output voltage rail shooted itself over 40 volts @ 6amps and at that moment all capacitors did their best effort to make a nice bang.

Resolution: Ripped up a cheap computer psu, and found myself a TL494, which would suit my needs, and also have much better adjustment posibilities for duty cycle limits.

Ill keep you guys posted if this one doesn't work ether :D

peace..

MY MICROCONTROLLER CAN BEAT THE HELL OUT OF YOUR MICROCONTROLLER /ATMEL

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

LOL!
Been there, done that (too!!!): Messing with the feedback, got out of regulation and the electrolytics went wild! Instantly, the room filled with grey snow... I could not even imagine the surprise I got!

You have to admit that this was a unique experience!

Giorgos.

I hope for nothing; I fear nothing; I am free. (Nikos Kazantzakis)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

MaxK,

Your audible noise source may also be from ceramic capacitors in your decoupling or filtering circuit.

Peter

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

@pdvorak:
you're absolutely right! Those tantalum caps exploded with very audiable beng!
No, the hissing noise was 99% sure coming from the big toroid. If i squeezed the copper wires the noise changed slightly.

RIP mc34063's...... all of them! :twisted:

Progress report:
I started working again from scratch, and reused the mosfet and the previously hissing torioid. This time i gave the TL494 a chance.. a hella lot of resistors are required to bring it alive, but if it works? thats fine.

Result: Flawless psu, no noise, stable, inrush and current limiting.

In short, im a happy monk :)

>> About Tantalum caps,
is it wise to squeze one or two tantalum caps on heavy current switching lines? Because ive previously used those caps a lot in low power circuits without problems..

PS: This is a picture from the web, but it kinda represents what happen to my previous psu attempt.

Attachment(s): 

MY MICROCONTROLLER CAN BEAT THE HELL OUT OF YOUR MICROCONTROLLER /ATMEL