New ways of fixing bugs in Studio? :(

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

A bug was reported with Studio 4.15 here https://www.avrfreaks.net/index.p...

I verified the it was not working with Studio 4.15 and as I use this feature frequently I posted an official bug report but did not even received an acknowledgment.

Hoping for a fix in Studio 4.16 I just installed it and now it is not even possible to click on the register name to change it.!! Novel way to fix things, if your head hurts we'll cut it off.

Watch does not work with the register for some reason, the stupid not in scope thing.

So I'll go back to Studio 4.14 for now and anyone else that needs that feature will need to do the same.

Attachment(s): 

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

js wrote:
So I'll go back to Studio 4.14 for now and anyone else that needs that feature will need to do the same.
Bummer. Hopefully you won't need to access an Xmega any time soon.

:twisted: Or you could switch to C and watch real variables! :evil: Nah, you'd probably want to watch local variables which are allocated to registers, bringing you back to where you started.

As I said, bummer.

Stu

Engineering seems to boil down to: Cheap. Fast. Good. Choose two. Sometimes choose only one.

Newbie? Be sure to read the thread Newbie? Start here!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:
Hopefully you won't need to access an Xmega any time soon.
I don't think so!! What's an Xmega anyway....

At least this time I got an automated reply from Atmel.

As you can see from above I tried and use "Watch" for temp but it does not work...just as much as it doesn't with C most of the time... :?

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly