New AVR Libc !!!

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

I just notice that AVR Libc released 1.4.5 which support 2560 and 2561!!! but I'm still using WinAVR 20060421, so how to lnclude the avr-libc-1.4.5 folder into the current WinAVR??

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Follow the advice that's been given in the avr-gcc forum. Do a search on the word "atmanavr"

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

> I just notice that AVR Libc released 1.4.5

That's why I posted an announcement into this forum here.

> which support 2560 and 2561!

Well, keep in mind that you need a GCC (and binutils, i. e. assembler
and linker) that are aware of the ATmega256x as well.

> but I'm still using WinAVR 20060421, so how to lnclude the
> avr-libc-1.4.5 folder into the current WinAVR?

If you can't / don't want to wait for the next WinAVR release, you
should always be able to extract the binary distribution of avr-libc
on top of your existing WinAVR installation. As the binaries are
solely intented for the AVR target, they are completely independent of
the host operating system (and architecture), i. e. there's the same
set of files regardless of whether you're running a Unix or Windows
machine. Again, see the announcement for the link to the binary
distribution.

Jörg Wunsch

Please don't send me PMs, use email if you want to approach me personally.