Need Help!!! Intersil HIP4081 problem

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi guys,

I have recently developed an 130W motor control board.

We seem to be facing a serious problem with HIP4081A driver failure which we can not explain. Generally the IC fails under load or Mortor stall condition even with current limits set at 3.5A @ Vlink = 30V.

Something we noticed today, is that sometimes both BHO and BLO (or both AHO and ALO) drive was on simultaneously. Is this possible? At the time of this change the IC was in the Enable state. This phenomenon causes a permanent damage on the IC and destroys the MOSFETs.

Can you please help shed some light on this issue? We should have already proceeded with CE approval and start up production for this design but we are running dangerously behind schedule.

Does anybody has any experience on the specific IC ?

I am attaching the schematic circuit.

Thanking you in advance.

Attachment(s): 

Michael.

User of:
IAR Embedded Workbench C/C++ Compiler
Altium Designer

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have no direct experience with the HIP4081AIB, however here are some ideas. The truth table does not include the cross conduction, so I would think your problem is noise related to the point that there is latch-up in the driver.

A way to proceed and trouble shoot may be to decrease the motor load by using a smaller motor or use a current limiting resistor in series. You also may want to consider increasing the gate resistor values and removing the speed up diodes to soften the gate drives. If the dead-band timing is too great that can lead to serious noise issues too. There also could be wiring and ground noise issues. By making the changes, you might have it working well enough to make improvements, with observations, work up to the load current you desire.

It all starts with a mental vision.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks for your kind reply.

Michael.

User of:
IAR Embedded Workbench C/C++ Compiler
Altium Designer

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

did you solve the problem?
I have the same problem

thanks for any help

 

 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Level: New Member

Joined: Mon. Dec 1, 2003

Posts: 1 View posts

 

WOW---where have you been for the past 16 years?  Welcome back!

When in the dark remember-the future looks brighter than ever.   I look forward to being able to predict the future!

Last Edited: Wed. Nov 13, 2019 - 04:36 PM