Mysterious flashing problems...

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I can't write anything to my ATmega8. I can read everything, but if I try to program anything, it locks, and displays all FF's, device signature, flash, eeprom, fuses, lock bits, all. After power down, everything reads as supposed to. I can't even erase the chip. Lock bits all read unprogrammed.

Also the chip heats up pretty much, even without anything connected to it.

This started after I left my programming cable attached to ISP header after programming, for about 10-20 minutes. I fine tuned my program and tried to program the mega, but all I get is "device unknown". That's the only thing I did that I haven't done before.

Using Pony-STK200 cable to program and PonyProg2000, checked if it works with another AVR, works. The mega is in a selfmade stripboard, that I've checked and has worked before. Power from old PC PSU. For clock I'm using VCXO which works, because the program that was left into the flash works.

Now, do I go get myself another mega or is there something that can be done ?