My atmega 128 is not responding

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

This is the error message I am getting..... :cry:
Somebody plz help me........

C:\WinAVR-20100110\bin>avrdude -p m128 -c usbasp -v

avrdude: Version 5.10, compiled on Jan 19 2010 at 10:45:23
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\WinAVR-20100110\bin\avrdude.conf"

Using Port : lpt1
Using Programmer : usbasp
AVR Part : ATMEGA128
Chip Erase delay : 9000 us
PAGEL : PD7
BS2 : PA0
RESET disposition : dedicated
RETRY pulse : SCK
serial program mode : yes
parallel program mode : yes
Timeout : 200
StabDelay : 100
CmdexeDelay : 25
SyncLoops : 32
ByteDelay : 0
PollIndex : 3
PollValue : 0x53
Memory Detail :

Block Poll Page
Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW Max
W ReadBack
----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ---
-- ---------
eeprom 4 12 64 0 no 4096 8 0 9000 90
00 0xff 0xff
flash 33 6 128 0 yes 131072 256 512 4500 45
00 0xff 0xff
lfuse 0 0 0 0 no 1 0 0 9000 90
00 0x00 0x00
hfuse 0 0 0 0 no 1 0 0 9000 90
00 0x00 0x00
efuse 0 0 0 0 no 1 0 0 9000 90
00 0x00 0x00
lock 0 0 0 0 no 1 0 0 9000 90
00 0x00 0x00
calibration 0 0 0 0 no 4 0 0 0
0 0x00 0x00
signature 0 0 0 0 no 3 0 0 0
0 0x00 0x00

Programmer Type : usbasp
Description : USBasp, http://www.fischl.de/usbasp/

avrdude: auto set sck period (because given equals null)
avrdude: warning: cannot set sck period. please check for usbasp firmware update
.
avrdude: error: programm enable: target doesn't answer. 1
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

avrdude done. Thank you.

what shall I do....

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

How is your programmer wired to the M128? A common mistake is to wire to MOSI/MISO but you need to wire to RXD/TXD (PE0/PE1)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Programmer is wired correctly.chip is in a development board.......

thank you for replying...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:
Using Port : lpt1
That can't be correct. Try -P usb