max3232pe

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hi folks!

first time in my life I connected a uC to my PC, and after a few mistakes it worked!
i was able to send data from mega48 over max3232pe to my pc!
but it doesn't work in the other direction!
signal comes on pin 13, but no change on pin 12!

any ideas?

there is just one thing: my caps are 2u around instead of 0.1 and 0.47 (minimum)! Can they be to big?

best regards

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Caps are probably OK. The chip is designed especially to be able to use smaller caps but it will be OK with larger.

Pin13 should be RS232 from the PC. Pin12 should be to the RX pin of the AVR UART. There is no "enable" on this chip. Can you verify that there really is no signal on pin12. If there is no signal, there is a good chance you have a short. Pin12 should be inverted with respect to pin13. That is, during the "idle" state between characters, the input voltage should be LOW (negative) and pin13 should be logic-high. If pin13 is not logic high when RS232 input is between characters, again, it is probably shorted to ground.

Jim

 

Until Black Lives Matter, we do not have "All Lives Matter"!

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

thanks, for your fast reply!

I think you got it! (I was really tired yesterday evening)
My problem was (hopefully, I will try it in a minute), that I have
a (don't know the english name) board full of drills and at the bottom
there a lines of copper! And I shortcut 2 of them unintentionally!

YEEAAHHH, it was it! I just tried it and it works! MAX is still alive! I love
shortcircuit protected parts :twisted:

Thanks a bomb!