M48 on STK500 and AVRStudio

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi Freaks,
I am trying to program my M48 on the STK500 with AVRStudio. I have all the connections right. My M48 is an Atmega48-20PU and is fresh from the store.

I am getting this ISP error. I tried changing the ISP so that it is less the 1/4th of clock freq. but no effect.

I am using JTAG MKII and the "green" socket on the STK500 board. Since the part is fresh from the store, I know I have to change the fuses somewhere. Can you please point me where in AVRStudio I can do this?
Thanks for your patience.

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'm very confused. In another thread you just apparently wasted days trying to get a Lady Ada USB-ISP programmer to work and yet all along you had TWO other ISP programmers (and one with USB while the other only needed the addition of a USB-RS232 adaptor). What was the point of that LadyAda side-track then?

Anyway, you say you are using both the STK500 and the JTAGICEmkII. How about if you just use the STK500 to do the ISP and forget the JTAG for the time being?

If the goal is simply to change the fuses in the m48 (presumably to set DWEN so you can use JTAGICEmkII as a debugger?) then plug m48 into that green socket SCKT3200A2, connect the 6 pin cable from ISP6PIN to SPROG2 and then instruct the STK500 to ISP program the device.

Cliff

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have the STK board and the JTAGICE MKII for a short time only (it's a friend's). I am still working on my ISP programmer. I am working on both in parallel. My plan was to use the STK500 to program my M48 for the time being.

I will try using the ISP interface to change the DWEN fuse so I can enable JTAG.

Thanks again for your patience.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Ok that worked. Sorry I should have realized this. :) Too many things going on. Thanks, Cliff.