Lock error - No device detected. Error 4109 - Erasing device...Failed!

Go To Last Post
2 posts / 0 new
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0



"Start debugging and Break" fails on my SAME70Xplained. It stops in the process at 5% erasing chip. I use SWD on EDBG as tool. I obtain "No Device Detected Error 4109".

I then do a reset with J200 jumper and obtain a "Lock Error" while erasing chip.

I did a hard reset as suggested in:


1. unplug the USB cable

2. add J200 jumper

3. plug in the USB cable

4. press and hold the reset button

5. unplug the USB cable

6. release the reset button and remove J200 jumper



1. plug in the USB cable

2. add J200 jumper

3. press and hold the reset button

4. unplug the USB cable

5. remove J200 jumper

6. plug in the USB cable

7. release the reset button

With these 2 methods I obtain "Timed Out : Waiting for the chip to erase to complete"


On Tool->Device Programming:

- Lock bits: No lock bits are ticked.

- Memories: when I clicked on Erase chip it fails.


I tried these steps on Atmel Studio v7 on Windows 7 and 10, with various cables and USB ports. It is most of the time recognised by windows as EDBG Data Gateway.

I tried to erase with Keil uvision 5 : Flash -> Erase and it says "Full Chip Erase Done" but when I switch to Atmel Studio the "erasing device" fails again.


Could you please advise? Thank you.


Last Edited: Thu. Apr 12, 2018 - 01:23 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Timestamp:    2019-03-12 16:23:06.727
Severity:        ERROR
ComponentId:    20100
StatusCode:    131121
ModuleName:    TCF (TCF command: Device:startSession failed.)

Could not activate interface, but found DAP with ID 0x2ba01477..

This usually indicates that the device is locked or in deep sleep. Try to do a chip erase to restore connectivity to the device.