Kernel compile - Linker problem???

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi!

I'm actually trying to compile the latest available kernel at avr32linux for my NGW100. After a lot of successfully solved problems, now I have a strange error.
When I type the following command:

root@smith-d820:/usr/src/linux-2.6.23.atmel.4# make ARCH=avr32 CROSS_COMPILE=avr32-linux- atngw100_defconfig

Also tried the targets 'menuconfig, gconfig'.
In all case I get the following error:

    HOSTCC scripts/basic/fixdep /usr/local/bin/ld: unrecognized option '--hash-style=both'
    /usr/local/bin/ld: use the --help option for usage information
    collect2: ld returned 1 exit status
    make[1]: *** [scripts/basic/fixdep] Error 1
    make: *** [scripts_basic] Error 2

The same command with the targets: 'mrproper' and 'help' works fine.

Running the command:

root@smith-d820:/usr/src/linux-2.6.23.atmel.4# avr32-linux-ld --hash-style=both --help

gives the following error:

    avr32-linux-ld: unrecognized option '--hash-style=both' avr32-linux-ld: use the --help option for usage information

I use Ubuntu 7.10. All needed packages are installed. First I installed them using 'apt-get install' method and later I installed the latest toolchain from Atmel website.

Someone please help!

Thank you in advance!

Peter Smith

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hmm...is it possible that you installed the avr32-linux cross-linker as /usr/local/bin/ld? "HOSTCC" indicates that the file in question is built using your native x86 toolchain, so the avr32-linux toolchain shouldn't have anything to do with it...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi how!

Thanks for the help! I tried to reinstall binutils from the package manager, but nothing changed. I got the same error message. So I (re)copied all files that I found in /usr/local/bin from /usr/bin. Maybe it is not the most elegant way solving the problem, but helped.....

I've been able to successfully compile my kernel....

Thank You a lot!

Best regards!

Peter Smith

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

peter_smith wrote:
Thanks for the help! I tried to reinstall binutils from the package manager, but nothing changed. I got the same error message. So I (re)copied all files that I found in /usr/local/bin from /usr/bin. Maybe it is not the most elegant way solving the problem, but helped.....

Might as well delete them from /usr/local/bin, then...
Quote:
I've been able to successfully compile my kernel....

Great :)