JTAGICE3 rescue after failed programming

Go To Last Post
7 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi.

Today I tried to update firmware version of JTAGICE3 (by usb hub...) from 2.15 -> 3 in Atmel Studio. Unfortunetly usb has been disconnected during programming.

Now, programmer is dead (diodes off, invisible for windows). It is possible to fix that?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

NOTE: I no longer actively read this forum. Please ask your question on www.eevblog.com/forum if you want my answer.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

"No tool is found" anyway I had this error when I tried to downgrade firmware (when jtagice3 was working). Is there any other solution?

All diodes are controlled by firmware program? It's not hardware problem?

Last Edited: Mon. May 18, 2015 - 04:56 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

LEDs are controlled by the firmware and in newer tools (Atmel-ICE and other EDBG-based boards) it is impossible to brick the device from the software. No matter what you do, the worst that will happen is device will get stuck in the bootloader mode. In this case it will blink the LEDs quickly.

 

I don't know if it is true for JTAGICE3.

 

In any case, device will have to be recognized by the system first.

NOTE: I no longer actively read this forum. Please ask your question on www.eevblog.com/forum if you want my answer.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Jtagice3 is unrecognized in other system where had been working correctly.

It seems that firmware-usb drivers of jtagice3 didn't install. It is possible to reprogram jtagice3 microcontroller by other programmer?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

I don't think so. Normally the firmware is sent in an encrypted form and is decrypted by the bootloader, so the chances of getting the firmware are slim.

 

Again, contact Atmel support and see what they have to say about it.

NOTE: I no longer actively read this forum. Please ask your question on www.eevblog.com/forum if you want my answer.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Solved, if we demount cover of jtagice3  there we can see two pads which start bootloader. We need to connect them eachother for ~1s. Next Atmel Studio will install driver normally.