JTAGICE mkII vs. Windows 7, 64-bit

Go To Last Post
9 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I installed AVR Studio 4 because I wanted avrdude to talk to a JTAGICE mkII.
It didn't work.
All I get is a yellow triangle.
The device manager can find JTAGICE mkII,
but it's not under jungo.
It's under other.
As noted in the subject, the target is a 64-bit Windows box.

What is the magic formula to make it work?

It's nasty enough that I have to install AVR Studio 4 just to get a driver.
That it doesn't work adds salt to the wound.

Telling the device manager to "scan for hardware updates" did the trick.
Fortunately.
Before I installed AVR Studio 4, a virtual serial port was functional.
Afterward, it wasn't.
"scan for hardware updates" cured that problem first.

I wrote too soon.
The device manager shows all is well,
but avrdude still can't find it.
IIRC this is an old problem,
but I still don't remember what to do about it.

"SCSI is NOT magic. There are *fundamental technical
reasons* why it is necessary to sacrifice a young
goat to your SCSI chain now and then." -- John Woods

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Michael,

This tutorial should explain all:

https://www.avrfreaks.net/index.p...

Cliff

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

clawson wrote:
This tutorial should explain all:

https://www.avrfreaks.net/index.p...

I still couldn't make it go.
The last time I did this, it was a long drawn out struggle,
one I don't intend to go through again if I don't have to.
I don't have to.
Using the new box for programming would be convenient,
but I don't need it.

"SCSI is NOT magic. There are *fundamental technical
reasons* why it is necessary to sacrifice a young
goat to your SCSI chain now and then." -- John Woods

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Do you have the Jungo USB 10.2 driver?

http://www.atmel.no/beta_ware/av...

Jungo USB installer version 10.2. This installer will fix USB connection issues with AVR Studio 4.18 SP3 and improve Windows 7 64-bit stability.

You never said which version of AVRstudio version you are using.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Mike B wrote:
Do you have the Jungo USB 10.2 driver?
JTAGICE mkII is listed under jungo.
I don't know how to tell the version of Jungo.
I don't remember the tutorial mentioning the Jungo version.
Quote:
http://www.atmel.no/beta_ware/av...

Jungo USB installer version 10.2. This installer will fix USB connection issues with AVR Studio 4.18 SP3 and improve Windows 7 64-bit stability.

You never said which version of AVRstudio version you are using.

AVR Studio 4.18 (build 684)

"SCSI is NOT magic. There are *fundamental technical
reasons* why it is necessary to sacrifice a young
goat to your SCSI chain now and then." -- John Woods

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Mike B wrote:
Do you have the Jungo USB 10.2 driver?

http://www.atmel.no/beta_ware/av...

Tried it. Didn't work. Got the T-shirt just so I could burn it.
Quote:
Jungo USB installer version 10.2. This installer will fix USB connection issues with AVR Studio 4.18 SP3 and improve Windows 7 64-bit stability.

You never said which version of AVRstudio version you are using.

"SCSI is NOT magic. There are *fundamental technical
reasons* why it is necessary to sacrifice a young
goat to your SCSI chain now and then." -- John Woods

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Mike B wrote:
Do you have the Jungo USB 10.2 driver?

http://www.atmel.no/beta_ware/av...

Tried it. Didn't work. Got the T-shirt just so I could burn it.
Quote:
Jungo USB installer version 10.2. This installer will fix USB connection issues with AVR Studio 4.18 SP3 and improve Windows 7 64-bit stability.

You never said which version of AVRstudio version you are using.

"SCSI is NOT magic. There are *fundamental technical
reasons* why it is necessary to sacrifice a young
goat to your SCSI chain now and then." -- John Woods

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

skeeve wrote:
Tried it. Didn't work.
Did you try SP3?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Mike B wrote:
Do you have the Jungo USB 10.2 driver?

http://www.atmel.no/beta_ware/av...

Jungo USB installer version 10.2. This installer will fix USB connection issues with AVR Studio 4.18 SP3 and improve Windows 7 64-bit stability.

You never said which version of AVRstudio version you are using.


Thanks! thet helped me. :)