Jtagice mk2 - "Unable to determine device"

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi

I have some problem on a new PCB where I use Atmega16 - 8ai with 8MHz internal RC clock as refference. The problem occoures when I trie to establish contact with the device through jtag interface (using latest rev. of studio). I can open the "select debug platform and device" window and do the required selections in here, and I can also open the platform options and select the correct frequency. However, when trying to debug, the chip wont load and studio replies with the message "Unable to determine current device, Please ensure that a device is selected for this project.". Belive me, the device is soo! selected that anyone whit the same amount of IQ as Avrstudio would reqognize it in a dark backyard at midnight. When using AVR-ISP dongle I can read and write the fuses, select and confirm the device signature, and I can also load the flash with code with no error messages. The problem is only related to the jtag ice interface. There is no other connections on the jtag io pins than a 10pin header. There is only a 100p cer. cond. connected from the Reset pin to gnd and a pullup on the reset pin to 5v reading 4k7 ohm. When opening the platform options and when reading the system flip, the device information says the target device and jtag id is "not probed". the voltage is read to be 5.136V and device manufacture is Atmel.

Have tried Atmel support, but they cant help. Have also checked the device batch number to be ok. All hw is checked, double checked and tripple checked including PCB tracks and soldering. And, as mentioned, have also tried to change the prosessor.

Any ideas or experience with this error message???

Mvh
Z

Regards
Vidar (Z)

----------------------------------------------------------

"The fool wonders, the wise man asks"