JTAG does not work but SWD does.

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I recently got a ATSAMV71N20 and an N21 and both work for SWD. JTAG on the other hand gives this error message:

Could not activate interface, but found DAP with ID 0x5b3d03f..

This usually indicates that the device is locked or in deep sleep. Try to do a chip erase to restore connectivity to the device.

Unable to enter programming mode. Verify device selection, interface settings, target power, security bit, and connections to the target device.

I'm using a socket just to test the jtag but all power is connected properly. When TST is held high with JTAGSEL also high (PD0 is low) I'm able to get this message. if TST is  held down, I can use SWD.

I already erased the chip and nothing. I really need it to be JTAG functional. Any suggestions or is there something missing? 

This topic has a solution.
Last Edited: Thu. Jul 22, 2021 - 11:02 PM
This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The JTAG Debug Port TDI, TDO, TMS and TCK is inactive. It is provided for Boundary Scan Manufacturing Test purpose only.

So is it the boundary scan you need? No other JTAG functions are available (I think from just looking at the datasheet).

/Lars

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yes I checked the datasheet a few days ago and that checks out. I was working on a board with 2 MCUs so it made sense to daisy chain them with JTAG.