ISP mode error - STK500 can't connect to AT90S8515

Go To Last Post
14 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hey, first of all i'm completely new to avr and working with microprocessors...

So i was following the "introduction to STK500 board"
(https://www.avrfreaks.net/modules...)
the part where you connect the cables and the power and the leds are supposed to lit up didnt work, so i supposed somebody flashed the processor before..

After i connected the STK500 board with avrstudio, which works, but after selecting the right microprocessor i get an isp mode error.

Like the message shows, i could try to change the frequency, but i dont know how.. when i change it in settings, it get's back to 57,60kHz

I'm using an AT90S8515 - 8PC processor,
and normally everything should be connected correctly.
here are some pics/screenshots.

http://img41.imageshack.us/img41...
http://img41.imageshack.us/img41...
http://img196.imageshack.us/img1...

and i'm using avrstudio 4.16

I looked for this problem on the forum and google but couldnt find any similar/a solution...

thanks for your help/time!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

You seem to have the jumpers set for using the STK500 clock. So go to HW Settings tab and set the clock to 3.6MHz and write it.

Then set your ISP frequency to 250kHz in the Main tab and try to Read the signature.

I notice that your 6 pin ISP jumper has the red stripe at the wrong end. This will work ok if you are backwards on both ends. You are less likely to make mistakes whn connecting to external boards if you follow the red-stripe to pin one convention.

David.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

thanks!
indeed that seemed to be the problem. Thanks for the tip for the jumper too.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi, I seem to be stuck with exactly the same problem. I've setup all the connections correctly, checking it sevrall times. Is there a logical explanation for this?

I've got quite an old stk500;
Hardware revision: 0x02
Firmware Version 0x020a

With the newest version of AVR Studio

And I am trying to progamm a ATtiny13

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

As far as I can remember you have to set qite a few jumpers to do a Tiny13.

Just read and re-read the manual.

David.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Ah,

good news, just put my old atmega8515 in their and it worked like a charm.

About the jumpers, what manual are you refering to?

edit:

just found a howto:
http://kaasxxx.wordpress.com/200...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:
what manual are you refering to?

The STK500 manual.

Regards,
Steve A.

The Board helps those that help themselves.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have the same problem. Stock STK500 setup with default jumper settings for everything. The first thing AVR Studio did was upgrade the firmware in the STK500 (to 0x020a).

The problem is that I keep getting "Entering programming mode... FAILED" messages for everything, no matter what I do. Evidently the USB->RS232 interface is working fine, because I can read and set values from the STK500 onboard controller.

FWIW, this is on a Vista 32-bit system. I've tried the sample ATmega8515L and ATMega16 chips that came with the system.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

1. compare each jumper with the STK500 manual. The AVRs go in different sockets. You only have one AVR at a time.

2. Set the ISP frequency to 250kHz

3. Set the STK500 clock to 3.6MHz i.e. full speed.

4. Read signature.

David.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks for the reply. I replaced the USB-to-serial adapter and now everything seems to be working fine.

The new USB-to-serial adapter is made by Dynex, model # DX-UBD9 ($36 at BestBuy, http://www.bestbuy.com/site/olspage.jsp?skuId=7135664&st=usb+to+serial&lp=1&type=product&cp=1&id=1110263657278 ).

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

It is far more interesting to hear of a cable that does NOT work. After all the STK500 does nothing clever with the serial port.

That seems an awful lot of money for a USB->RS232 cable. But all the items on that website seem expensive.

So I would be inclined to test both your cables with a regular Hello World.
And if the old one works, try in the STK500 control port again.

David.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The one that didn't work was made by Belkin, model F5U409.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Belkin is a perfectly respectable make.
You can download the drivers from their website.

Seriously, I would just try it again with the STK500.
Then download and install any new drivers, and try again.

David.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Oh believe me, I've tried the Belkin cable a dozen different ways over two days, with all the right drivers. It just doesn't work with my combination of laptop and Vista. I'm as surprised as anyone, though, as Belkin stuff is usually pretty good.