IP Address of STK1000

Go To Last Post
13 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have an working ethernet and RS232 connection with the STK1000. If I run ifconfig I get

eth0 Link encap:Ethernet HWaddr 00:04:25:19:02:4C
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1720 (1.6 KiB) TX bytes:18880 (18.4 KiB)
Interrupt:25 Base address:0x1800

returned instead of a valid IP address - what am I doing wrong? Do I have to manually configure the IP address for the STK1000?

Regards, Mike.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If you don't have a DHCP server on your network, you need to set your IP address manually.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

You could either use the dhcp-client (udhcpc) or set an static ip via ifconfig (i.e. ifconfig eth0 1.2.3.4)

11011110101011011100000011011110

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

From the STK1000 BSP docs

Quote:
The STK1000 Linux environment can be configured as a DHCP server, which is useful for standalone testing with a single PC. This can be done by editing the /etc/init.d/network script and commenting out (prepending a '#' on) the line that reads "DHCP=client". Note that this may cause problems if you connect your STK1000 to a network where other computers use DHCP for network configuration.
If though you do have a DHCP server on the network, something deeper is crook. Try setting a static IP as above and report back!

Cheers,
S.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

@Jokerman,
Also check ethernet cable. I had the same problem @ first the I replaced the ethernet cable and my problem was solved.

Cheers,

Alex van der Lans

You can find me @ skype as: alex1678

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

You might also want to check that the jumper setting of Sw6 on the STK1002 is correct.

edit: SW6, not SW0...

Last Edited: Mon. Aug 28, 2006 - 01:48 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks to all,

I configured the IP address manually and that did the trick - I am doing dev on a laptop thats never been connected to a network via ethernet. I've finally got my 'hello world' program to load and run :D

Regards, Mike.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Good feeling, isn't it!? Good luck in your dev!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hi i do a manual configuration but i can't ping from PC to STK1000 neither STk to PC

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Does running ifconfig give you a correct ip address? How are the stk and pc connected (crossover cable/ through hub/ across the world)? Do both ends have the link light active on the rj45 connector?

-S.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

stk and pc are connect through hublink lights are active

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

And all IPs are correct, on the same subnet etc?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

it's ok now i can ping they weren't on the same subnet