Interrupt vector suppression

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Does anyone know how to suppress the generation of the interrupt jump table?

I ported the bootloader to gcc, but the jump table is taking up alot of un-needed space.

Thanks,
Mike H.

admin's test signature
 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi Mike,

You could specify -nostartfiles as a linker option and provide your own init file. gcrt1.S is the source for all of the ctrxx.o files used as your start file that are used based upon your processor selection. Copy this file into to source directory and make necessary modifications to remove the vector table. This is the file that calls main.

John

admin's test signature
 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I tried the -nostartfiles option which did work. I tried to manually remove the vector table from the Gcrt1.S file, but it still places it the output. I'm curious now where it really gets the vector table info??? :) Is there an option to specify your own startup file ?

Thanks,
Mike H.

admin's test signature
 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Well, I'm going with the -nostartfiles option and just adding my init in assembler.

When using the -nostartfiles option I usually get a avr-obj error and it aborts on the first build. Then if I build again I get error 256 file not found. Then if I build a third time I don't get any errors and everything compiles fine.

Is this normal or is there another flag I should be setting somewhere?

Thanks again :)
Mike H.

admin's test signature