ICE works fine with AS6.2 but doesn't even appear in list for AS7

Go To Last Post
11 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi Gents,

 

I reinstalled AS7 and AS6.2 recently after some issues I was having on my comp and my 2 ICE programmers are working fine on AS6.2 but they don't even show up on AS7 like the did previously.

 

I was previously on AS7 v 7.0.780 and I am now on 7.0.1006. SO im not 100% sure what is going on. Whether my drivers are out of date since I uninstalled all atmel related stuff.

 

But I am yet to find how to upgrade them if that is the situation.

 

My Driver details are as follows:

Date: 5/1/2013

Version: 1.0.0.0

Signer: Atmel Norway

 

I am unsure what has happened in the case of my programmers since I havn't changed the firmware on them at all :(

 

Any suggestions would be awesome!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Which programmers? ICE2 or ICE3?

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Not sure I can answer that question.

 

I purchased this one :)

 

http://www.atmel.com/tools/atatm...

 

I just uninstalled as 7.0.1009 and reinstalled as 7.0.790 which appears to be roughly 300mb larger than 7.0.1006 offline thinking that something could be missing in the latest release.

 

Thus I installed 7.0.790 without updates and the ICE started working :D

 

Now trying to install updates over the top over 790 to try once more.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hmh, the latest release is about 30 megs larger actually (talking from memory).

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

ICE2 or ICE3?

What's that?

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Oh shit, you're right, guess that installer is broken :|

 

Nonetheless, r790 with the ICE is picked up fine. Did the web update from r790 to r1006 and the ICE is no longer picked up.

 

Might have to stick to r790 at this stage then.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

ryanafleming wrote:
the ICE is no longer picked up.

What does usbdeview.exe say?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I should say that it was not longer picked up by AS7 specifically, at the same time the simulator wasn't displayed either :). I could also still use tools to upgrade the firmware on my ICE so there was no issues with that.

 

Nonetheless...

 

I redownloaded the offline version of AS7 1006 and removed all previous atmel software and installed 1006 once more. It picked up the ICE programmer this time but it seems I keep getting an error now that it cannot find any toolchain.

 

"Required toolchain is missing or corrupt. Please repair Atmel Studio installation from 'Add or Remove programs'".

 

Did the repair, not change. Also uninstalled the toolchain manually leaving studio there, reinstalled, no change. </3

 

Looks like its back to AS6.2 for me.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

ryanafleming wrote:
I should say that it was not longer picked up by AS7 specifically, at the same time the simulator wasn't displayed either :)

Which suggests that atbackend.exe has failed to launch. What do the logs say?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Also, try to start studio as admin (right click etc) and see if things become visible.

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

clawson wrote:

ryanafleming wrote:

I should say that it was not longer picked up by AS7 specifically, at the same time the simulator wasn't displayed either :)

 

Which suggests that atbackend.exe has failed to launch. What do the logs say?

 

I did have a warning when I started previously about "atbackend" not starting., that would explain that component. Reinstalling fixed this issue though and it seems that I am stuck with a new one.

 

meolsen wrote:

Also, try to start studio as admin (right click etc) and see if things become visible.

 

After reinstall, running as admin still gives me the "Requried toolchain is missing or corrupt" message. I think it might have something to do with visual studio 2015 since I installed it once, broke my studio, so I went back to 2013 and it was working fine until more recently when I tried to upgrade as7.

 

Currently I am running VS2013 Community with AS6.2 and AS7. VS2015 was uninstalled before AS7 installation. I also attempted to do the fix that was stated in other threads about the VS2015 Update using a new library file. So I replaced that as well. 

 

No deal :(