How to use Strictly Atmel Studio - No Arduino - No Visual Micro ?

Go To Last Post
9 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

This is my new question after posting the infamous:

"Why is _delay_ms_ behave unpredictably ?" question.

Seeing that so much differences were alleged between Visual-Studio-Visual-Micro and Atmel-Studio I decided to investigate further by going 100% Atmel-Studio7 AS7 and only, strictly AS7 so as to put aside any discrepancies between pure AVR and Arduino layer.

It didn't take long for me to run into another problem all together, And that is:

How do you program an ATtiny85 with AS7 without Arduino IDE?

 and

How do you get rid of Visual-Micro within AS7 and keep my Visual-Studio-Visual-Micro installation intact?

After downloading AS7 and installed it as per instructions, at first start Visual-Micro showed up with the Arduino IDE (by default), What  ! ? ! ? !  Is there anything simple in this world of MCU ?crying

Thanks for your help guys

PS: I finally deducted that the OP means the guy who is asking the top question in a post, but curiosity is almost infinite, where is this OP expression comes from, Open Publisher ? Original Posting ? ....Operator Pimp? laugh

Last Edited: Fri. Apr 19, 2019 - 09:29 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

OK! I just found how to get rid of VisualMicro in my AS7 installation.

Now I can edit a code for an ATTiny85 with AS7.

I can initiate a Build and I can get a functioning file type *hex from the \Release\ folder.

I'M up and running smiley with AS7 clean No Visual Micro and No Arduino IDE.

Question closed.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

What made you post this question in the ARM related Studio forum? It seems that you are working with a simple Tiny85.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

js wrote:

What made you post this question in the ARM related Studio forum? It seems that you are working with a simple Tiny85.

The question is oriented toward AS7 after venturing in this problem with the ATtiny85 and timing discrepancies.

It seemed logical to me that the subject of the AS7 question was not related to ATtiny85 itself but to a more general implementation problem altogether.

The solution was simply to go to AS7 menu Tools/Extension and Updates/ and UnInstall Visual-Micro. I was then able to have a clean AS7 programming environment for my ATtiny85.

Now I'm back to my original project with a clean AS7.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The question is oriented toward AS7

I understand but we have 2 forums for AS7, one is AVR related and the other is ARM related. I'll move the thread them.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly