How to render a tiny2313 useless

Go To Last Post
7 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Just set the clock option to 128KHz, hit Program, ignore the warning by the STK500 programmer and press OK.

I just don't see why they made this interesting option (at 128Khz divided by 256 it runs at just 500Hz ;) ), but made it so that it disables any further programming. High voltage programming is disabled in STK500 dialog box.

This option is just useless this way. Is this a bug as the tiny2313 still isn't fully developed? I know there is an issue with parallel programming. Anyone know of a way to re-enable programming? There is no mention of it in the datasheet that this clock option disables any further programming.

Jeroen

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Slow down your programming to an appropriate rate. Try the canned 32kHz that AVRStudio provides, or enter even slower values for the STK500 until you can correct the fuse situation.

Lee

You can put lipstick on a pig, but it is still a pig.

I've never met a pig I didn't like, as long as you have some salt and pepper.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I tried that, even down to 14.1hz with safe mode, but to no avail. Maybe the silicon revision doesn't allow it, the date code is 3104.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Btw, what was the warning from the STK500 programmer?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Something like "if you select this option together with the CLKDIV/8 fuse further programming will be impossible" :) I'm not sure it will give this warning with the 'Smart warnings' box unchecked.

The date code is 0431, so I guess this silicon still has the (HV) programming bug. I downloaded the latest version of AVRStudio and upgraded my STK500 and HV is now available, but that doesn't work, also not for the other tiny2313 I have. This issue is also listed in the known issues in the STK500 manual. But nowhere is mentioned that you can't use the 128KHz clocking mode.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I just tried this with my STK-500 and my part still works after I dropped the ISP frequency to 1.206 kHz. The STK500 Oscillator was still set at 3.69 MHz. I enabled the clock output on PD2 and got 15.7 kHz square wave.

The warning message is:
WARNING! Using this clock option together with the CKDIV8 fuse will disable further programming!

That message only appears when changing the 128 kHz clock option even with the CKDIV8 fuse disabled. It doesn't show up when enabling/disabling the CKDIV8 fuse with the 128 kHz clock option already selected.

In case it matters, I upgraded the STK-500 software to the dreaded version 2 before doing any of this.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Did anyone wor out how to "fix" this problem? i have one tiny2313 i cant program cause i enabled the watchdog timer as the main clock and i have one that seems to only work intermittently. are there any more kown problems with the tiny2313 that i should be aware of because i only have 2 left.

Daniel