How to re-enable SPI with Studio 7 and Atmel-ICE

Go To Last Post
7 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'm using an ATmega88 and I was able to switch to debugWire to debug my code with Studio 7.

Now I'd like to switch it back to SPI to use the Device programming interface, but I can't re-enable it.

I remember that in Studio 4 there was a button (or maybe a menu) I had to press to let the software do that for me, but I'm unable to find the same function on Studio 7.

From the Atmel help I found this: http://www.atmel.com/webdoc/atme... but I can't find the disable debugWIRE command in my menu.

 

Any help?

Attachment(s): 

This topic has a solution.
Last Edited: Fri. May 27, 2016 - 06:46 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Start debugging.

In the Debug Tab under the "Start Without Debugging" there should be "Disable debugWire and Close"

 

David

This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Go to Tools->Select Profile and apply the advanced profile. It should then reappear.

 

Alternatively, update to 7.0.943 and reset the Standard profile as written in the 7.0.943 release note.

:: Morten

 

(yes, I work for Microchip, yes, I do this in my spare time, now stop sending PMs)

 

The postings on this site are my own and do not represent Microchip’s positions, strategies, or opinions.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

meolsen wrote:

Go to Tools->Select Profile and apply the advanced profile. It should then reappear.

 

That did the trick, thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Using Studio 6 (ver: 6.2.1563-Service Pack2)

Can debug just fine but cannot read device signature and cannot program program.

Tried selecting ISP, Release and other things.

I used to be able to program on a previous project (same micro), but now I can't anymore.

Error Message I get:

Unable to enter programming mode. Pleas verify device selection, interface settings, target power and connections to the target.

Target voltage measures 3.0V

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

oresto wrote:
Using Studio 6 (ver: 6.2.1563-Service Pack2)

That's very old, and Studio 6 was known to be buggy.

 

What debug probe are you using; eg, Atmel-ICE ?

 

Can debug just fine but cannot read device signature and cannot program program.

That doesn't make sense - it won't enter debug without reading the device signature.

 

Are you trying to read device signature and program via ISP ?

 

You need to exit debugWIRE mode before you can use ISP again. You do that by starting a debug session, then there's an option to exit & switch to ISP - pay attention to the instructions about when to power-cycle.

 

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks, that helped. I did get it working. It just wasn't obvious. All ok now. Thank you.