How to disable the JIT debugger ?

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Since i installed AS5 on my old notebook (HP Pavilion, WinXP SP3) everytime an application crashes ( old games etc... )it opens a dialog where i'm asked if i want to use the Just-In-Time debugger to debug the crashed appliciation. If i answer to use the JIT debugger it responds that my license is invalid ( of course, 'cause i have the AVR edition, not the M$ Visual Studio IDE for Win32) .If i answer no , the system hangs for a few minutes and then returns to the desktop. This is annoying - anyone knows of a way to disable that 'feature' ?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

If i answer to use the JIT debugger it responds that my license is invalid ( of course, 'cause i have the AVR edition, not the M$ Visual Studio IDE for Win32)

That's a VS2010 thing - I get that on machine with the win32 version of VS2010 -the same error about licence not valid. Yet if I start VS2010 standalone there is no problem - so it's something about it trying to start in the context of an application crash. (maybe the licence "belongs" to your user account but it's trying to launch on behalf of some other user - perhaps "admin"?)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Check out http://msdn.microsoft.com/en-us/...(v=VS.100).aspx - scroll down to the section that describes how "To disable Just-In-Time debugging by editing the registry".

Regards

Senthil

 

blog | website

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Wow, Senthil that is just what i've been looking for. Thanks a bunch !

@clawson: I've only one user on this system and he's the admin :P Hpw did you manage the launch the VS2010 standalone ? I've neither VisualC nor VBasic on this system (except for a few run-time extensions) , only AS5 'powered by VisualStudio' .

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

Hpw did you manage the launch the VS2010 standalone ?

I'm talking about a virtual machine where I have Visual Studio 2010 C++ installed. (in fact I don't dare install AS5 in that VM in case it buggers things up!)