How Change Output Directory?->Atmel Studio 6.2

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi @all,

i have asked my friend google but he had no answer for my problem. So i ended up here.

Is it possible to change the directory anyhow? I know the option in Visual Studio and also in AVR Studio < Version 5.

I tried to change the path under properties. The properties flashs up on the right sight when i click on the outputfile in the Solution Explorer. There is a property which is called "path" but i can´t change it because it´s colored grey and i have no right to do that.

Thx

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

As far as I know you can not change the location of where the output files go. They always end up in a subfolder to the project folder, and with the name of the subfolder being the same as the name of the configuration you are building.

Why do you need this?

You could of-course add a post-build step that copies the output files to some other location of your choice.

As of January 15, 2018, Site fix-up work has begun! Now do your part and report any bugs or deficiencies here

No guarantees, but if we don't report problems they won't get much of  a chance to be fixed! Details/discussions at link given just above.

 

"Some questions have no answers."[C Baird] "There comes a point where the spoon-feeding has to stop and the independent thinking has to start." [C Lawson] "There are always ways to disagree, without being disagreeable."[E Weddington] "Words represent concepts. Use the wrong words, communicate the wrong concept." [J Morin] "Persistence only goes so far if you set yourself up for failure." [Kartman]

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

As far as I know, we don't allow the output to be moved. Too many hard-coded assumptions on the location around the system.

As Johan says, easiest is to do a copy as a post-build task to wherever you want.

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi Johan,

i have copied the porject folder from my fellow. After starting and building it, i have got a successful note at the bottom. And here is the thing, the outputfile (.hex) didn´t change in date. So my issue is that i can´t translate the project. The funny thing is that the path from the outpufile (how i described on my first post) equates to the path form the copied project location. Have anyone made the same experience?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

guys,....

i found the solution in my bloody boned bravery. :D After deleting all of the ouputfiles i had success. it´s working now!!!!

thx for listening me ;)