GLcd G128641A using avrlib

Go To Last Post
9 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi all,
I have just rebuild the example code glcdtest.c given in avrlib/examples/glcd.
I am not able to initialize the graphic lcd correctly.

GLCD used - G128641A
Control port is PortC
Data port is Port A

Lcd hardware connections are good.


But the problem is the lcd is initialized with 8 horizontal lines.

I have attached an image of output screen.
Kindly help me in debugging this problem.

Thanks

Attachment(s): 

Last Edited: Wed. Jan 5, 2011 - 05:49 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:
Kindly help me in debugging this problem.

Without code, huh ? THAT'LL cost you plenty !!

1) Studio 4.18 build 716 (SP3)
2) WinAvr 20100110
3) PN, all on Doze XP... For Now
A) Avr Dragon ver. 1
B) Avr MKII ISP, 2009 model
C) MKII JTAGICE ver. 1

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

Quote:
Without code, huh ?

have send you an attachment,i thought people might be having it.

Thank you Indie :)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

OK, but you have to attach it HERE. You should just edit attach it into your last post .

Moderator wrote:
But the problem is the lcd is initialized with 8 horizontal lines.

Do you mean that they're there because its coded to put the 8 lines on display ?

1) Studio 4.18 build 716 (SP3)
2) WinAvr 20100110
3) PN, all on Doze XP... For Now
A) Avr Dragon ver. 1
B) Avr MKII ISP, 2009 model
C) MKII JTAGICE ver. 1

Last Edited: Wed. Jan 5, 2011 - 06:16 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Ok,i have attached it now.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

divgup, see my last post ? to the mod. Check the code and see if the lines ARE in the code as part of initialization.

1) Studio 4.18 build 716 (SP3)
2) WinAvr 20100110
3) PN, all on Doze XP... For Now
A) Avr Dragon ver. 1
B) Avr MKII ISP, 2009 model
C) MKII JTAGICE ver. 1

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Sorry but what has the moderator got to do with any of this? Just because an OP chose to use some red text does not mean a moderator added a comment. I'm in the habit of making moderator comments [in square brackets] and js makes them in $ Asm style dollar signs $

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

OOps, Pavlovian of me. Still, the GLCD init. code WORKS, so it seems to me like the lines would have to be in the code. OP you ought to check on that. Track down lcd_out.png ( which might be used in the main code ), since it's exactly the image that appears in your OP display. .

Also where is the code at by the time it prints those 8 lines and text ? That way only code at and above that point has to be looked at.

1) Studio 4.18 build 716 (SP3)
2) WinAvr 20100110
3) PN, all on Doze XP... For Now
A) Avr Dragon ver. 1
B) Avr MKII ISP, 2009 model
C) MKII JTAGICE ver. 1

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hey,
Last week i didn't get time to update the forum
Then i came across a document of arduino library for ks0108.http://www.arduino.cc/playground/uploads/Code/GLCD_Documentation.pdf.
The connections were not good,i rewired the board and lcd initialization is working fine.

Cheers :)