Getting started w/ AS6, AVR One, and external compiler

Go To Last Post
8 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'm transitioning from AS4 to AS6. I compile with ICCAVR and debug with AVR One. With AS4 I could just open the .cof and start debugging. Not so with AS6. I've read the docs and they're heavily slanted toward ASF and GCC projects developed within AS6. If I try to open a .cof it just shows me the bits. I can program my device via the emulator and AS6, so that stuff works, but I can't actually emulate. Can someone give me some pointers for setting up a project for debugging as I've described? Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I thought the extension gallery had an Imagecraft plugin to aid the integration of ICC?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'm only on AS6 6.0 (upgrading now), but my extension manager doesn't show anything for Imagecraft or ICCAVR.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Sorry, my bad. There's an extension for CV but not ICC.

However you should be able to open COF files with File-Open-Open Object File For Debugging. The file selector there certainly mentions *.cof - does that not work for you?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yup, just found that (probably while you were typing). That's what I was looking for. Thanks. Now, however, I can't seem to get out of debug mode. When I click on the Stop Debugging button, debugging stops, but I can't read or write anything through the Emulator and Device Programming dialog as I was able to do before debugging. I repeatedly get "Unable to enter programming mode" warnings. Something else I need to do?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Based on some other threads here, it looks like turning off debugging isn't enough to switch the emulator from debugWire back into ISP mode, but I haven't been able to find instructions for what needs to be done to do that. Do you have any idea? The only relevant option I've found is a Tool screen that let's me change between ISP and debugWire, but changing to ISP doesn't solve my problem.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Uhm, as Dean and David already said in the other thread, it's right there in the Debug menu (Obviously greyed out unless you have an open debug session)

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Aaah, got it. Missed it somehow in the other thread. Works as advertised. That's incredibly messed up, putting it there, not providing a shortcut, and differentiating it from the normal Stop Debugging command. Oh, well. Thanks!