FYI: FW Upgrade problems - JTAGICE mkII with AVRStudio 4.14

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I had an interesting (read: frustrating) experience trying to upgrade the firmware in my AVR JTAGICE mkII after upgrading to AVRStudio 4.14. Each time I tried to upgrade I would get a failure part-way through.

The failure varied: failure to write some particular block (always a different one) or failure to prepare for write. The first time the upgrade tried to work it was initiated from AVRStudio. All other times was using the JtagIIUpgrade.exe app (see your \Atmel\AVR Tools\JTAGICEmkII directory).

I was finally able to reliably (and repeatedly - I didn't trust the first success! :wink: ) upgrade by turning off all applications on my system. There was some interaction in a timing sense between some app on my system and the upgrade app.

I'm posting here so that anyone else having a similar problem can try shutting down everything but the upgrade app. "It worked for me!" :D

Stu

PS: This is being sent as a bug report to the powers-that-be at Atmel.

Engineering seems to boil down to: Cheap. Fast. Good. Choose two. Sometimes choose only one.

Newbie? Be sure to read the thread Newbie? Start here!