Failed to enter programming mode.

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

My situation: pcb with AT90USB1287, connected through ISP to Atmel-ICE. 

It has been working fine for weeks, and now I get the message.

 

Failed to enter programming mode. ispEnterProgMode: Error status received: Got 0xcc, expected 0x00 (Unknown status message)

Unable to enter programming mode. Verify device selection, interface settings, target power, security bit, and connections to the target device.

 

Timestamp:    2021-09-28 16:07:29.169
Severity:        ERROR
ComponentId:    20100
StatusCode:    1
ModuleName:    TCF (TCF command: Device:startSession failed.)

Failed to enter programming mode. ispEnterProgMode: Error status received: Got 0xcc, expected 0x00 (Unknown status message)

I have seen other messages where the recieved status was 0xC0, but mine is 0xCC.

What does that mean?  

Is my chip broken? Or my Atmel-ICE?

 

 

 

 

Last Edited: Wed. Sep 29, 2021 - 08:05 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

1. Check USB cable?

2. Verify Atmel-ICE (and it's connector cable) connection with any other board, maybe check connecting to arduino read it from ISP?

 

After those two, verify your board.

“Everyone knows that debugging is twice as hard as writing a program in the first place. So if you're as clever as you can be when you write it, how will you ever debug it?” - Brian W. Kernighan
“Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.” - Antoine de Saint-Exupery

Last Edited: Tue. Sep 28, 2021 - 02:31 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Ribbon cables can break, most can be fixed by prying off the 2x3 connector, sliding it down the cable and clamping it at the new spot, trim off the excess cable.....

Other possibilities, no target power?  AVR left in debugWire mode, Not sure if the this AVR uses DW or not.   Wrong pins used for ISP....

 

FF = PI > S.E.T

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The problem is fixed (at least for now). Somewhere else on the forum I read about the hint of setting the ISP clock all the way down to 8 kHz. Only then it was able to read the signature. Programming then timed out, but then I put the clock back to the default value and then everything worked again.

I'm not sure what caused the problem, though.