External makefile in Atmel Studio error

Go To Last Post
2 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi Guys,

 

Forgive me if I have this in the wrong forum, couldn't think where to post this thread.

 

I downloaded bitcloud, the atmel zigbee stack and I am trying to compile one of the default applications, ZLLDemo.

It is located currently at: "C:\Users\Ryan\Desktop\BitCloud_MEGARF_3_1_0\Applications\ZLLDemo\atmelStudio_projects\ATmega256RFR2.cproj"

 

Everytime I try to compile the application I get a windows message screen for "mkdir" error 0xc0000142. In the Output screen I see the line "make: *** [directories] Error -1073741502"

 

I have the following things to fix the error:

  • Change folder and contents to different owners, everyone having full privileges
  • run make command manually from a command prompt window as admin
  • clean solution before retrying
  • all other examples files
  • ran directly from C: as "C:\BitCloud_MEGARF_3_1_0\Applications\ZLLDemo\atmelStudio_projects\ATmega256RFR2.cproj"
  • as per general suggestion for the windows error I tried
    • "sfc /scannow" in case mkdir had somehow been corrupted
    • Changed AppInitDLLs Reg key to 0 to load all DLLs at start of application
    • Disabled Internet security

 

Does this have a general fix or is there perhaps something else at work here? General compilations work, its just external ones. My friend did the same and it seems to work just fine for him.

 

Windows 8.1

Atmel Studio 6.2

 

Cheers,

Ryan.

Last Edited: Fri. Oct 16, 2015 - 12:38 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Well -1073741502 is just 0xc0000142 anyway so there's basically just one error code here. If you Google you don't find much about -1073741502 but you do hit a lot of traffic about 0xc0000142 which seems to suggest its an application init error because some required components are missing. I'm guessing that when "make" runs it might be wrong make being used or there could be an installation problem for the one it is trying to use.

Changed AppInitDLLs Reg key to 0 to load all DLLs at start of application

Ah, I see you googled already - as you'll have read that is a common fix for 0xc0000142

 

I think I'd contact the suppliers of "BitCloud" and see if anyone else has been afflicted by this previously. With that in mind and because there's no other response to this thread I'll move it to the Wireless forum.