Error upgrading the WINC1500 firmware

Go To Last Post
2 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello:

 

I had to upgrade WINC1500 firmware but I'm getting the attached error. ( [ERROR] Found more than one matching tool. Please specify serial number.

 

I tried with both SAMG55 board and SAMD21 but I get same error in both cases...

Before starting the update, I updated Atmel Studio to the latest version, and this caused the edbg to request for an update. After this, v.3.22 was loaded into the edbg debugger.

In the case of SAMD21, after this edbg upgrade, I noticed an MSD USB class was installed so every time I power up the board via the EDBG connector, a Windows Explorer opens up for this MSD drive. 

 

I'm not sure what's wrong, but I can't update the WINC1500 at all. Now, WINC1500 firmware reports v. 0.0.0 

I would appreciate any help on this.

 

Thanks

Gus

 

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I was able to solve the issue, adding the -s ATML2393031800003922 option in the firmware/download_all_sb.bat file for each line invoking the atprogram.exe 

 

However, I'm still wondering what changed in the edbg since the last update...

 

Gus