error : telnetd is missing

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I get this code when I start my ngw100 board :

init started:  BusyBox v1.4.2 (2007-04-17 15:34:55 CEST) multi-call binary
 * mounting virtual filesystems: /proc /sys /dev /dev/pts /config /tmp /var/run /var/lib/samba /var/log 
 * set mdev hotplug ...          [ OK ]
 * mdev ...                      [ OK ]
 * setting hostname ...          'ngw.example.net'
 * network loopback ...          [ OK ]
 * starting syslogd ...          [ OK ]
 * log messages to syslog ...    [ OK ]
 * starting klogd ...            [ OK ]
 * probing modules ...           vfat loaded, mmc_block loaded, atmel-mci loaded, [ OK ]
 * mounting filesystems:         /usr 
 * setup eth0 ...                [ STATIC ] (10.11.12.1)
 * setup eth1 ...                [ OK ]
 * network ...                   [ OK ]
 * starting telnetd ...          [ MISSING ]
 * enable ipv4 forwarding ...    [ OK ]
 * iptables postrouting ...      [ MISSING ]
 * starting dnsmasq ...          [ MISSING ]
 * running ntpdate ...           [ MISSING ]
 * starting dropbear ...         [ MISSING ]
 * starting inted ...            [ MISSING ]
 * starting nmbd ...             [ MISSING ]
 * starting httpd ...            [ MISSING ]
 * get board type for GPIO ...   'NGW'
 * setup GPIO boot LED ...       [ OK ]
 * setup GPIO LED A ...          [ OK ]
 * setup GPIO LED B ...          [ OK ]

Network Gateway ready

I boot whit my original image and modules then I get this error message. The same is when I use the image that I build. Until yesterday all worked OK.

I can't use my telnet connection or my web interface. I don't receive any IP from the board.

I work whit my board yesterday, but I didn't modify any important files, only work whit the SPI driver.

Please help me. :?

my second board is still broken, I can to nothing to my project.

Update data : I took a look in /etc/ini.d in S20telnet file and I sow that 'which telnet' is the problem.
If I do 'which telnetd' will return nothing.
The busybox has this command build in,I sow this in currently defined function after i write 'busybox'.

How could I fix my problem ?pls.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

You probably miss a symlink from telnetd to busybox in either /sbin or /usr/sbin. Perhaps your system is not properly populated with symlinks from when you installed Busybox?

How did you make the system, which build tool did you use, or did you make it by hand?

You can run telnetd by "busybox telnetd".

Hans-Christian

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:
You probably miss a symlink from telnetd to busybox in either /sbin or /usr/sbin. Perhaps your system is not properly populated with symlinks from when you installed Busybox?

Maybe this is the problem.I look in /sbin and /bin and I don't have the symlink to busybox.

Quote:
How did you make the system, which build tool did you use, or did you make it by hand?

It was working for a week. Now i;m using the 2.6.18.version and I get the same error.

Quote:
You can run telnetd by "busybox telnetd".

Yes. this is ok.

I use telnet last tine it work, 2 connection. Today when I power on the ngw100 board I get the message.

So, if i can do a symbolik link to busybox think that will work ? If yes, please tell me where it should be and how to create it.

Thanks for the quick answer.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

update:

I output the config files (ex: S20telenet) and i sow that 'which telnet' return no value. So, I went to /sbin folder and
'ls -al'
and no telnet was there.type
'busybox'
and you will see the commands that are build in. telnet and telnetd are, so I create a symbolic link like that:
ln -s ../bin/busybox telnet
ln -s ../bin/busybox telentd
I reboot and now I got that message ok.

 * mounting virtual filesystems: /proc /sys /dev /dev/pts /config /tmp /var/run /var/lib/samba /var/log
 * set mdev hotplug ...          [ OK ]
 * mdev ...                      [ OK ]
 * setting hostname ...          'ngw.example.net'
 * network loopback ...          [ OK ]
 * starting syslogd ...          [ OK ]
 * log messages to syslog ...    [ OK ]
 * starting klogd ...            [ OK ]
 * probing modules ...           vfat loaded, mmc_block loaded, atmel-mci loaded, [ OK ]
 * mounting filesystems:         /usr
 * setup eth0 ...                [ STATIC ] (10.11.12.1)
 * setup eth1 ...                [ OK ]
 * network ...                   [ OK ]
 * starting telnetd ...          [ OK ]
 * enable ipv4 forwarding ...    [ OK ]
 * iptables postrouting ...      [ MISSING ]
 * starting dnsmasq ...          [ MISSING ]
 * running ntpdate ...           [ MISSING ]
 * starting dropbear ...         [ MISSING ]
 * starting inted ...            [ OK ]
 * starting nmbd ...             [ MISSING ]
 * starting httpd ...            [ OK ]
 * get board type for GPIO ...   'NGW'
 * setup GPIO boot LED ...       [ OK ]
 * setup GPIO LED A ...          [ OK ]
 * setup GPIO LED B ...          [ OK ]

so telnet is ok.