Error compiling Fontconfig 2.4.2

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'm having trouble cross compiling fontconfig 2.4.2. My configure line looks like this:

./configure --build=i686-pc-linux-gnu --host=avr32-linux --with-arch=avr32 --prefix=/usr/local/avr32-linux --with-freetype-config=/usr/local/avr32-linux/bin/freetype-config --disable-docs --enable-libxml2 PKG_CONFIG_PATH=/usr/local/avr32-linux/lib/pkgconfig CC=avr32-linux-gcc

then make fails in fc-lang with:
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../src -I.. -I/usr/local/avr32-linux/include/freetype2 -I/usr/local/avr32-linux/include -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -g -O2 -MT fc-lang.o -MD -MP -MF ".deps/fc-lang.Tpo" -c -o fc-lang.o fc-lang.c; \
then mv -f ".deps/fc-lang.Tpo" ".deps/fc-lang.Po"; else rm -f ".deps/fc-lang.Tpo"; exit 1; fi
gcc -g -O2 -o fc-lang fc-lang.o
rm -f fclang.h
./fc-lang -d . aa.orth ab.orth af.orth am.orth ar.orth as.orth ast.orth ava.orth ay.orth az.orth az_ir.orth ba.orth bam.orth be.orth bg.orth bh.orth bho.orth bi.orth bin.orth bn.orth bo.orth br.orth bs.orth bua.orth ca.orth ce.orth ch.orth chm.orth chr.orth co.orth cs.orth cu.orth cv.orth cy.orth da.orth de.orth dz.orth el.orth en.orth eo.orth es.orth et.orth eu.orth fa.orth fi.orth fj.orth fo.orth fr.orth ful.orth fur.orth fy.orth ga.orth gd.orth gez.orth gl.orth gn.orth gu.orth gv.orth ha.orth haw.orth he.orth hi.orth ho.orth hr.orth hu.orth hy.orth ia.orth ibo.orth id.orth ie.orth ik.orth io.orth is.orth it.orth iu.orth ja.orth ka.orth kaa.orth ki.orth kk.orth kl.orth km.orth kn.orth ko.orth kok.orth ks.orth ku.orth ku_ir.orth kum.orth kv.orth kw.orth ky.orth la.orth lb.orth lez.orth ln.orth lo.orth lt.orth lv.orth mg.orth mh.orth mi.orth mk.orth ml.orth mn.orth mo.orth mr.orth mt.orth my.orth nb.orth nds.orth ne.orth nl.orth nn.orth no.orth ny.orth oc.orth om.orth or.orth os.orth pa.orth pl.orth ps_af.orth ps_pk.orth pt.orth rm.orth ro.orth ru.orth sa.orth sah.orth sco.orth se.orth sel.orth sh.orth si.orth sk.orth sl.orth sm.orth sma.orth smj.orth smn.orth sms.orth so.orth sq.orth sr.orth sv.orth sw.orth syr.orth ta.orth te.orth tg.orth th.orth ti_er.orth ti_et.orth tig.orth tk.orth tl.orth tn.orth to.orth tr.orth ts.orth tt.orth tw.orth tyv.orth ug.orth uk.orth ur.orth uz.orth ven.orth vi.orth vo.orth vot.orth wa.orth wen.orth wo.orth xh.orth yap.orth yi.orth yo.orth zh_cn.orth zh_hk.orth zh_mo.orth zh_sg.orth zh_tw.orth zu.orth < ../fc-lang/fclang.tmpl.h > fclang.h
gez.orth
: can't open
make[1]: *** [fclang.h] Error 1

As you can see it compiles fc-lang with the build's gcc (i686) but with includes from avr32. (i tried a older version 2.3.something and had problems at the same spot, except it build it with avr32-linux-gcc but then tried to run it on the build host).

I know that a few people here have got fontconfig to work (or at last got GTK to work so i assume they got fontconfig to work). It would be great if they could share they're configure line and any patching they had to do.