Dragon Reads Signature, Once (Solved)

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Lots of threads on Dead Dragons... I'm not sure if this behavior is symptomatic of a dead/dying dragon, or just Operator Error.

Knowing that the Dragon is a sensitive device, I have it on a Dragon Rider, (Ecros Tech), purchased pre-assemblied from another forum member.

Read the manual, several times, installed a bunch of jumpers and a Tiny2313, plugged in the USB cable.

AVR Studio will connect to the Dragon and read the ATTiny2313 Signature, ONCE. ("Signature matches selected device"). Try to read it a second time and get an ISP Mode Error: "Entering programming mode. FAILED!". Try again: "Setting device parameters. Failed!"

If I close the AVR Studio connection box, and then Re-connect again, it again reads the signature, ONCE.

Tried it with two new Tiny2313's. Put an external Xtal on the board, (just in case).

I have the ISP speed at it's slowest setting.

Connecting and closing the connection box in AVR Studio flashes the Dragon LEDs and Win XP "dings" to indicate the USB connection is made or broken as appropriate.

Nothing else is tied to the Tiny pins.

As the Dragon Rider board is basically just routing the signals to a couple sockets, similar to a STK500, I suspect the problem is the Dragon.

Any thoughts on this Connect Only Once behavior?

JC

Last Edited: Wed. Mar 11, 2009 - 06:48 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

I have the ISP speed at it's slowest setting.

Try 125KHz and make sure you write it so it stays.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Wow!

Thank you! That was a quick fix. It reads the signature correctly now.

Off to work now, but will download a program to the chip tonight, and make sure that that all works.

Thank you!

JC