Does MPLAB X IDE support ATMegas and the AVR DRAGON?

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

My main OS is Linux (Mint), so I've been trying to create a project for an ATMega644A. My programmer/debugger board is an AVR Dragon. However, when I open the new project wizard, I don't see any ATMega chips during the device selection step. I have read about people using MPLAB to write their projects with ATMegas. I've been researching this off and on for weeks, and I finally give up, so here I am asking for help laugh

 

I have a Windows 10 Pro VM in VirtualBox, and AS detects the AVR Dragon in that, but the VM causes frequent spikes in CPU usage, which is annoying, and it takes up several GBs of RAM. So that's why I'm trying to get MPLAB X IDE to let me make a project for an ATMega644A, since MPLAB runs in Linux.

 

Am I doing something wrong?

 

The version of MPLAB X IDE is v4.15. Thanks

Do not expect the neutral zone to save you.

Last Edited: Wed. Oct 23, 2019 - 05:13 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

AVR support was introduced in MPLAB X 5.00, but it has improved since then and is now at 5.25: https://www.microchip.com/mplab/.... I strongly recommend you to upgrade to the latest version of MPLAB X.

 

The Dragon is not and will not be supported by MPLAB X. But the SNAP should be a nice replacement for it. There is a thread about it here on Freaks: https://www.avrfreaks.net/forum/...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Alright, I'll try 5.25. Thanks!

Do not expect the neutral zone to save you.