Device Revision: issues - AS5.1 and AS6 JTAG Programming -

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Almost all Atmel data sheets containg SERIOUS ERRATA - some errata is SO BAD it is beyond belief that the part is actually sold for MONEY and not given away free to someone who has lots of hair and hates paying for haircuts!!

There has to be a way to determine what is the revision number of the part we are working on in order to determine which ERRATA apply to our part, there is such a thing in Atmel Studio Device Programming.

Problem is not all verisons of AS work correctly, if you have AS5.1 and it does not report the Revision of the MCU you are interested in you would reasonably assume [incorrectly] that it is not available when in fact it is but AS5.1 is not reporting it because some Atmel Engineer has found time to GO BACK OVER WORK THAT WAS ALREADY DONE CORRECTLY in an earlier version of AS and STUFF IT UP!!

Only reason I can think of for doing this is they are they worried that if everything works one day and there are no bugs to report they will lose their jobs, you know Empire Building with a twist.

JTAG - Programming - Device Information -

Tried AVR ONE! with ATmega1280
AS5 displays "Revision B"
AS5.1 has a blank space where Revision should be
AS6 has a blank space where Revision should be

Before anyone jumps down my throat! Yes, I did try to post it in the bug list but it will not let me log in.

Tried AVR ONE! with AT32UC3C0512C
AS5 Reports Revision E
AS5.1. BLANK LINE
AS6 Reports Revison 4

Hekp me out here, is this correct, one starts with AS5 and if something doesn't work, one tries 5.1 then 6.

Or does one start with AVR32 Studio then progress up through the other Studios.

Tried AVR ONE! and AT32UC3B0256 ES
AVR32 Studio reports Revision B
AS5 reports Revision B
AS5.1 blank line
AS6 "Revision: Read Device ID from chip to retrieve version"

I thought the AVR Programmer HW+SW was supposed to display the Revision number, not display instructions to persuade me to write some code to do the job of the Programmer.

AVR32 Studio reports the Device name UC3B0256ES [got that absolutely right], but on the Processor TAB it reports "Architecture Type 0(AVR32A)"