Debugging issues

Go To Last Post
7 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I built my project for the XMega256A3 with Imagecraft toolchain then I was used to open the .cof file with AVR Studio 4 to debug it with the JTAGICE MKII.
I'm trying the new AVR Studio 5 and saw the Open object file for debugging.
Didn't understand why it has to create a new folder somwhere for the project source, but I let it go.
Now I press Start debugging and break and every time I have my eeprom is fully erased.
How can I prevent it?

Another question: I often switch the power of the target to have a restart, because the micro I'm debugging is part of a complex system and it has to communicate with some other micros, so switching off the power is the easiest way to reboot all the micros at the same time and be sure that the communication will be on.
With the AVR Studio 4 this was transparent to me, now with AVR Studio 5 I get this annoying windows that tells me that the target power is off.
Can it be disabled?

Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi.

Thanks for trying out AVRStudio5!

1. The unconditional erasing of eeprom is a bug we are aware of. It will be changed to be more like AVRStudio4.

2. The message window you are seeing on target power off is also something we will change to be much less intrusive.

Regards,

Torleif Sandnes
Atmel Norway

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi again.

For future reference:

1. The unconditional erasing of eeprom has issue number 13777
2. Message on target power off has issue number 13803.

Torleif

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If you are an Imagecraft user it would be interesting to hear if you have been able to set up AVRStudio 5 so you can use AVR Studio 5 as IDE for ICCAVR.

/Bengt

My favorites:
1. My oscilloscope, Yokogawa DLM2024.
2. My soldering iron, Weller WD2M, WMRP+WMRT.
3. JTAGICE3 debugger.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'm sorry, but we give up using studio 5 and we decided to stay with 4, until we find some time to test the new version some more.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

If you are an Imagecraft user it would be interesting to hear if you have been able to set up AVRStudio 5 so you can use AVR Studio 5 as IDE for ICCAVR.

What would be the point? I thought that Imagecraft V8 now uses Eclipse as its IDE - what would VS2010 deliver that Eclipse doesn't?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Imagecraft v 8 is using Code Blocks. I do not use Imagecraft version 8, only 7.

My favorites:
1. My oscilloscope, Yokogawa DLM2024.
2. My soldering iron, Weller WD2M, WMRP+WMRT.
3. JTAGICE3 debugger.