Controlling GCC Toolchain in Studio V2.6

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi All

Does anyone know whether it is possible to configure AVR32 studio V2.6 to use the GCC 4.3.2 tool chain (located elsewhere on the PC) rather than the GCC 4.3.3 tool chain that it installs as a plug-in?

The reason being that the new compiler version fails (internal crash) with an existing project and so, rather than alter optimisation settings to avoid the error, the older GCC version would like to be used instead.

Regards

Mark

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

mjbcswitzerland wrote:
Hi All

Does anyone know whether it is possible to configure AVR32 studio V2.6 to use the GCC 4.3.2 tool chain (located elsewhere on the PC) rather than the GCC 4.3.3 tool chain that it installs as a plug-in?

The reason being that the new compiler version fails (internal crash) with an existing project and so, rather than alter optimisation settings to avoid the error, the older GCC version would like to be used instead.

Regards

Mark


This is just a guess, but I think you might be outa luck on this one. I think switching to the plugin mechanism eliminates the previous method of invoking the tools. As always I could be wrong on this one. My frustration is breaking projects by adding things causing dependency error cascades. This is like trying to balance an inverted pendulum.

We never have time to do it right,
but we always have time to do it over

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

From what I read it is always an option to uninstall toolchain plugin and put your toolchain in PATH environment variable.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

What Manneveru says: There's a description in the release notes.