"... contains a device 'AT32UC3A3256' which is not supported..."

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Title says it all.

 

I performed an upgrade from AS 7.0.634 to 7.0.790 and existing projects that I tried to load failed with "The project "proj_name"  contains a device 'AT32UC3A3256' which is not supported by Atmel Studio. Please select another device.".

Headed back to the AS7 product page and checked that the UC3A3256 et al _is_ supported (I would have had a hard time believing that they skipped the UC3, though).

 

FWIW, VS2015 is on the same machine.

 

I have downloaded the complete offline installer, ~825 MB just to be sure, but no difference.

 

Where did I go wrong ?

 

best,

Chris

 

Edit: I attached a log file from the VS output window after opening an existing project.

I see a lot of "Runtime.InteropServices.COMException" exceptions, so maybe my installation is broken...

 

 

Attachment(s): 

Last Edited: Sat. Mar 19, 2016 - 03:39 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 

same (almost) with me. Upgrade to 7.0.790 using the web installer.

After the upgrade I get a similar error message targeting a different device (ATmega2560). The same worked before the update.

 

Any solution?

 

Thanks and best regards

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

A coworker reported this to Atmel via a ticket and they said it could be related to the "Device Support Package" in AS7, build 790.

 

Resolution proposal:

 

>  1.) Open Atmel Studio 7
>  2.) Go to (Tools->Device Pack Manager)
>  3.) Under UC3A_DFP you will have 1.0.51 pack, check the checkbox and uninstall the pack.
>  4.) If you have 1.0.46 pack under UC3A_DFP, uninstall that as well.
>  5.) Close Atmel Studio
>  6.) Go to http://packs.download.atmel.com/ and download (1.0.46 Initial release) package under Atmel UC3A Series Device Support (1.0.51) as shown in image.
>  7.) Install the downloaded file using Device Pack Manager.

 

>  Try building your project now. It should build.

 

Since we had to finish a project that week, we just re-installed Win10 and AS 7.0.790, and it worked right away. We also installed VS2015 and the WDK10 / SDK10 on the same machines later on, no problems with that either.

 

I cannot say what it was or if that above procedure works - at least Atmel knows about it.

 

Hope that helps!

 

Regards,

Chris

 

 

Last Edited: Tue. Mar 29, 2016 - 04:39 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks for the detailed explanation.

I will give it a try in the next days.

 

Best regards

 

robenke