conFUSED about FUSEs in studio 4.10

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

This is only my third day of playing with AVRs, so I'm an AVR newbie. I'm using the new AVR Studio 4.10, JTAGICE MKII, STK500/501, mega 128L and assembler 2 beta 5.

Using the STK500 to program the OCDEN (on chip debug) fuse and the preserve EEPROM from erasure fuse works.

However, as soon as I debug with the JTAGICE MKII both of these two fuses get cleared (both STK500 and JTAGICE MKII show them cleared).

The 4.10 documentation * claimed * that clearing the EEPROM fuse when using JTAGICE MKII had been fixed :evil:.

Even though the OCDEN debug fuse is cleared, the break op-code still works under JTAGICE MKII. Since break is an on chip debug op-code, it appears the fuse must be set, at least while the JTAGICE MKII is debugging.

Am I crazy (rhetorical question only :)) or is anyone else out there seeing this also? On the other hand, maybe I am missing some fundamental understanding of JTAGICE MKII, AVR Studio 4.10 or something?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The OCDEN fuse is handled automatically by the JTAGICE. It will be programmed when you start the debugging session and erased when you leave (just remember that if you just remove power/software crash during debugging it will be left programmed). The EESAVE I can't help you, but have you checked the emulator options dialog box? It is possible there is a setting in this box that overrides the initial fuse setting.

Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks for the reply and info. You are correct. I went back to look for another setting on the EEPROM fuse and found this:

Under Debug on the main menu, there is a “Select Platform and device” choice. When selected I get a “Select Device and debug platform” dialog window. This window has a check box for “Open platform options”, which I check. I also select JTAGICE mkII and Atmega128. Then after I start a Debug session, a “JTAGICE MKII” dialog window opens up with the following 3 tabs:
Connection, Debug and Status

The connection tab is where I have been entering the correct target clock frequency for the JTAG connection and I am using USB for the actual connection.

Everything under the entire Debug tab is grayed out, including the “Preserve EEPROM contents” check box. I had been ignoring this entire window because it was all grayed out :oops:. I can’t get into this window to allow any selections at all. I also tried entering it from the Project Wizard with no luck.

BTW, The JTAGICE is working for both target programming and debugging. I also upgraded the JTAGICE MKII and STK500 firmware. The updated MS XML software was also installed on a Win 2000 Pro OS.

Can anyone tell me how to get into the grayed out Debug window and set the Preserve EEPROM contents check box?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

In the spirit of a "shotgun" approach, I installed the updated XML 4 SP 2. MS said both versions can run concurrently, so they can both be installed. It did no harm, but I still can not access the grayed out JTAGICE MKII DEBUG window.

The preserve EEPROM flag problem was a know bug in the last 4.09 release. Going back to the old release will not solve the problem either.

Can anyone help me get into the DEBUG window?