Compile errors not jumping to position in file

Go To Last Post
6 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi all,
I have a problem with using compile error in the build window. When I compile a single 'C' source file - compile errors are generated in the build window. When I double click an error line in the build window, the editor window does not focus on the file and line containing the error or warning. And - although the line number for the error is stated in the error report, I cannot find a way to switch line numbering on in the edit windows.

My tools are setup as follows:
Using WinAVR from 2007/05/25
Using AVR Studio - Ver 4.13 : Service pack 1 - build 557
My project is using an external make file - The project is the USB-CDC sample project from Atmel to which I have added some additional C source files. It is one of these additional files that I compile and have the problem with. In fact I have this problem with any file compiled - or with building the project.

Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The current line number is shown in the status bar -so just move the cursor to the line in question

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Ok, that already helps a lot. I missed it because I was looking at the left bottom, not the right bottom.

Is this situation a result of using an external make file? Can I do something to fix it?

Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I've had it not able to position to the errors even when using it's own Makefile so, no, I don't think it's simply because of using an external Makefile. There's something else going wrong.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Did you ever find a cause? I am having the same problem. In my case I am trying to compile an Ethernut application. (GCC & AVR Studio 4.13 bld 528)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I know it's bad form to reply to myself but ... I appear to have found the answer in a later thread in this forum. When I turn off "external makefile" "jum to the line in error" works again ...