Build not finding necessary header file

Go To Last Post
6 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Trying to work with Xplained Pro SAML21 and some sample code.

Some source files include the header file saml21.h but the build environment is not finding it, so I get errors.

 

How do I add a header file location to the build configuration?

 

Thanks

Last Edited: Wed. Apr 17, 2019 - 08:35 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

How did you make the project? What version of the DFP? What is the build error?

 

You should not add that header, it is normally included...

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I just edited my post.

 

It's a manufacturer-supplied example project.  I'm just opening the proj file.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

... and the build output?

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If the example code is #including that file, then it's wrong, it should #include sam.h

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks for the help so far.

 

meolsen wrote:

If the example code is #including that file, then it's wrong, it should #include sam.h

That may be, but changing it in the two place that reference it still gives the same error. "No such file or directory"

 

I have 59 "sam.h" files scattered on my PC - which is the one that my build should be using?

And how does Atmel Studio know where to look for the proper include files?